Learn R Programming

REAT (version 3.0.3)

krugman.spec: Krugman coefficient of regional specialization for two regions

Description

Calculating the Krugman coefficient for the specialization of two regions based on regional industry data (normally employment data)

Usage

krugman.spec(e_ij, e_il)

Arguments

e_ij

a numeric vector with the employment of the industries \(i\) in region \(j\)

e_il

a numeric vector with the employment of the industries \(i\) in region \(l\)

Value

A single numeric value (\(0 < K_{jl} < 2\))

Details

The Krugman coefficient of regional specialization (\(K_{jl}\)) is a measure for the dissimilarity of the industrial structure of two regions (\(j\) and \(l\)) regarding the employment in the \(i\) industries in these regions. The coefficient \(K_{jl}\) varies between 0 (no specialization/same structure) and 2 (maximum difference, that means there is no single industry localized in both regions). The calculation is based on the formulae in Farhauer/Kroell (2013).

References

Farhauer, O./Kroell, A. (2013): “Standorttheorien: Regional- und Stadtoekonomik in Theorie und Praxis”. Wiesbaden : Springer.

Nakamura, R./Morrison Paul, C. J. (2009): “Measuring agglomeration”. In: Capello, R./Nijkamp, P. (eds.): Handbook of Regional Growth and Development Theories. Cheltenham: Elgar. p. 305-328.

See Also

gini.conc, gini.spec, krugman.conc, krugman.conc2, krugman.spec2, locq

Examples

Run this code
# NOT RUN {
# Example from Farhauer/Kroell (2013), modified:
E_ij <- c(20,10,70,0,0)
# employment of five industries in region j
E_il <- c(0,0,0,60,40)
# employment of five industries in region l
krugman.spec(E_ij, E_il)
# results the specialization coefficient (2)

# Example Goettingen:
data(Goettingen)
krugman.spec(Goettingen$Goettingen2017[2:16], Goettingen$BRD2017[2:16])
# Returns the Krugman coefficient of regional specialization 2017 (0.4508469)
# }

Run the code above in your browser using DataLab