Learn R Programming

REAT (version 1.2.1)

gini.spec: Gini coefficient of regional specialization

Description

Calculating the Gini coefficient of regional specialization based on regional industry data (normally employment data)

Usage

gini.spec(e_ij, e_i)

Arguments

e_ij
a numeric vector with the employment of the industries $i$ in region $j$
e_i
a numeric vector with the employment in the industries $i$

Value

A single numeric value ($0 < G_{j} < 1$)

Details

The Gini coefficient of regional specialization ($G_{j}$) is a special spatial modification of the Gini coefficient of inequality (see the function gini()). It represents the degree of regional specialization of the region $j$ referring to $i$ industries. The coefficient $G_{j}$ varies between 0 (no specialization) and 1 (complete specialization).

References

Farhauer, O./Kroell, A. (2013): “Standorttheorien: Regional- und Stadtoekonomik in Theorie und Praxis”. Wiesbaden : Springer.

See Also

gini, gini.conc

Examples

Run this code
# Example from Farhauer/Kroell (2013):
E_ij <- c(700,600,500,10000,40000)
# employment of five industries in the region
E_i <- c(30000,15000,10000,60000,50000)
# over-all employment in the five industries
gini.spec (E_ij, E_i)
# Returns the Gini coefficient of regional specialization (0.6222222)

# Example Freiburg
data(Freiburg)
# Loads the data
E_ij <- Freiburg$e_Freiburg2014
# industry-specific employment in Freiburg 2014
E_i <- Freiburg$e_Germany2014
# industry-specific employment in Germany 2014
gini.spec (E_ij, E_i)
# Returns the Gini coefficient of regional specialization (0.2089009)

Run the code above in your browser using DataLab