Learn R Programming

REAT (version 1.2.1)

krugman.spec: Krugman coefficient of regional specialization

Description

Calculating the Krugman coefficient for the specialization of two regions based on regional industry data (normally employment data)

Usage

krugman.spec(e_ij, e_il, e_j, e_l)

Arguments

e_ij
a numeric vector with the employment of the industries $i$ in region $j$
e_il
a numeric vector with the employment of the industries $i$ in region $l$
e_j
a single numeric value reflecting the employment in region $j$
e_l
a single numeric value reflecting the employment in region $l$

Value

A single numeric value ($0 < K_{jl} < 2$)

Details

The Krugman coefficient of regional specialization ($K_{jl}$) is a measure for the dissimilarity of the industrial structure of two regions ($j$ and $l$) regarding the employment in the $i$ industries in these regions. The coefficient $K_{jl}$ varies between 0 (no specialization/same structure) and 2 (maximum difference, that means there is no single industry localized in both regions).

References

Farhauer, O./Kroell, A. (2013): “Standorttheorien: Regional- und Stadtoekonomik in Theorie und Praxis”. Wiesbaden : Springer.

See Also

gini.conc, gini.spec

Examples

Run this code
# Example from Farhauer/Kroell (2013), modified:
E_ij <- c(20,10,70,0,0)
# employment of five industries in region j
E_il <- c(0,0,0,60,40)
# employment of five industries in region l
E_j <- 100
E_l <- 100
# over-all employment in regions j and l
krugman.spec(E_ij, E_il, E_j, E_l)
# results the specialization coefficient (2)

Run the code above in your browser using DataLab