Usage
gini.spec(e_ij, e_i, lc = FALSE, lcx = "% of objects",
lcy = "% of regarded variable", lctitle = "Lorenz curve",
le.col = "blue", lc.col = "black", lsize = 1, ltype = "solid",
bg.col = "gray95", bgrid = TRUE, bgrid.col = "white",
bgrid.size = 2, bgrid.type = "solid", lcg = FALSE, lcgn = FALSE,
lcg.caption = NULL, lcg.lab.x = 0, lcg.lab.y = 1,
add.lc = FALSE, plot.lc = TRUE)
Arguments
e_ij
a numeric vector with the employment of the industries \(i\) in region \(j\)
e_i
a numeric vector with the employment in the industries \(i\)
lc
logical argument that indicates if the Lorenz curve is plotted additionally (default: lc = FALSE
, so no Lorenz curve is displayed)
lcx
if lc = TRUE
(plot of Lorenz curve), lcx
defines the x axis label
lcy
if lc = TRUE
(plot of Lorenz curve), lcy
defines the y axis label
lctitle
if lc = TRUE
(plot of Lorenz curve), lctitle
defines the overall title of the Lorenz curve plot
le.col
if lc = TRUE
(plot of Lorenz curve), le.col
defines the color of the diagonale (line of equality)
lc.col
if lc = TRUE
(plot of Lorenz curve), lc.col
defines the color of the Lorenz curve
lsize
if lc = TRUE
(plot of Lorenz curve), lsize
defines the size of the lines (default: 1)
ltype
if lc = TRUE
(plot of Lorenz curve), ltype
defines the type of the lines (default: "solid"
)
bg.col
if lc = TRUE
(plot of Lorenz curve), bg.col
defines the background color of the plot (default: "gray95"
)
bgrid
if lc = TRUE
(plot of Lorenz curve), the logical argument bgrid
defines if a grid is shown in the plot
bgrid.col
if lc = TRUE
(plot of Lorenz curve) and bgrid = TRUE
(background grid), bgrid.col
defines the color of the background grid (default: "white")
bgrid.size
if lc = TRUE
(plot of Lorenz curve) and bgrid = TRUE
(background grid), bgrid.size
defines the size of the background grid (default: 2)
bgrid.type
if lc = TRUE
(plot of Lorenz curve) and bgrid = TRUE
(background grid), bgrid.type
defines the type of lines of the background grid (default: "solid"
)
lcg
if lc = TRUE
(plot of Lorenz curve), the logical argument lcg
defines if the non-standardized Gini coefficient is displayed in the Lorenz curve plot
lcgn
if lc = TRUE
(plot of Lorenz curve), the logical argument lcgn
defines if the standardized Gini coefficient is displayed in the Lorenz curve plot
lcg.caption
if lcg = TRUE
(displaying the Gini coefficient in the plot), lcg.caption
specifies the caption above the coefficients
lcg.lab.x
if lcg = TRUE
(displaying the Gini coefficient in the plot), lcg.lab.x
specifies the x coordinate of the label
lcg.lab.y
if lcg = TRUE
(displaying the Gini coefficient in the plot), lcg.lab.y
specifies the y coordinate of the label
add.lc
if lc = TRUE
(plot of Lorenz curve), add.lc
specifies if a new Lorenz curve is plotted (add.lc = "FALSE"
) or the plot is added to an existing Lorenz curve plot (add.lc = "TRUE"
)
plot.lc
logical argument that indicates if the Lorenz curve itself is plotted (if plot.lc = FALSE
, only the line of equality is plotted))