Learn R Programming

VLF (version 1.1)

VLF.count.spec: VLF Count for Specimens

Description

Calculates the number of very low frequency variants (VLFs) for each specimen in a matrix of sequence nucleotide frequencies.

Usage

VLF.count.spec(freq, p, seqlength)

Value

A vector containing the number of VLFs for each specimen in the matrix.

Arguments

freq

A matrix of nucleotide frequencies for each specimen.

p

A very low frequency variant designation vut off frequency. Any frequency in the freq matrix below this value is considered to be a very low frequency variant.

seqlength

The length of the sequences.

Author

Taryn B. T. Athey and Paul D. McNicholas

Details

The argument freq can be calculated using the function specimen.frequencies.

Examples

Run this code
if (FALSE) data(birds)
species.names <- birds[,2]
specimen.Number <- nrow(birds)
rownames(birds) <- species.names
Nuc.count <- count.function(birds, specimen.Number, 648)
frequency.matrix <- ffrequency.matrix.function(Nuc.count, 648)
birdSpec.freq <- specimen.frequencies(frequency.matrix, birds, specimen.Number, species.names, 648)
Bird_specimen_VLFcount <- VLF.count.spec(birdSpec.freq, 0.001, 648)

Run the code above in your browser using DataLab