if (FALSE) {
## tensor product `tescv' example
require(scam)
simu <- function(x,z) { sin(2*x) - 4*z^2 }
xs <-seq(0,1,length=30); zs <- seq(-1,1,length=30)
pr <- data.frame(x=rep(xs,30),z=rep(zs,rep(30,30)))
truth <- matrix(simu(pr$x,pr$z),30,30)
set.seed(5)
n <- 500
x <- runif(n)
z <- 2*runif(n)-1
f <- simu(x,z)
y <- f + rnorm(n)*.2
## fit model ...
b <- scam(y~s(x,z,bs="tescv"))
summary(b)
old.par <- par(mfrow=c(2,2),mar=c(4,4,2,2))
plot(b,se=TRUE)
plot(b,pers=TRUE,theta = 50, phi = 20);title("tescv")
plot(y,b$fitted.values,xlab="Simulated data",ylab="Fitted data",pch=".",cex=3)
persp(xs,zs,truth,theta = 50, phi = 20);title("truth")
par(old.par)
vis.scam(b,theta = 50, phi = 20)
}
Run the code above in your browser using DataLab