Estimates the parameters of a distribution using autodiff.
# S3 method for tsdistribution.spec
estimate(
object,
solver = "nlminb",
control = list(trace = 0, eval.max = 300, iter.max = 500),
use_hessian = TRUE,
...
)
An object of class “tsdistribution.estimate” with slots for the estimated coefficients, gradients, scores etc.
an object of class “tsdistribution.spec”.
only “nlminb” currently supported.
solver control parameters.
whether to use the hessian in the calculation.
additional parameters passed to the estimation function
The estimation makes use of the TMB package for minimizing the negative of the log-likelihood using automatic differentiation.