Learn R Programming

tsdistributions (version 1.0.2)

tsprofile.tsdistribution.spec: Model Parameter Profiling

Description

Profiles the model parameters under the specified distribution.

Usage

# S3 method for tsdistribution.spec
tsprofile(
  object,
  nsim = 100,
  sizes = c(800, 1000, 1500, 2000, 3000),
  seed = NULL,
  trace = FALSE,
  ...
)

Value

An object of class “tsdistribution.profile”.

Arguments

object

an object of class “tsdistribution.spec” with pre-set parameters.

nsim

the number of paths to generate.

sizes

a vector of data sizes for which to simulate and estimate.

seed

an object specifying if and how the random number generator should be initialized. See the simulate documentation for more details.

trace

whether to show the progress bar. The user is expected to have set up appropriate handlers for this using the “progressr” package.

...

not currently used.

Details

The function profiles the parameters of a model by simulating and then estimating multiple paths from the assumed distribution. This makes it possible to obtain a better understanding of the convergence properties (RMSE) of each parameter under different data sizes.